Deufol status of IT services - Citrix web is back up – Incident details
IT Helpdesk
Get updates
Email
SMS
Microsoft Teams
IT Helpdesk
Get updates
Dark mode
Language
All systems operational
Citrix web is back up
Resolved
Major outage
Started 4 months ago
Lasted about 2 months
Affected
Citrix workspace
Operational from 5:18 AM to 5:18 AM, Major outage from 5:18 AM to 12:02 AM
Updates
Resolved
06.03.2026 at 12:02
Resolved
06.03.2026 at 12:02
Citrix workspace is back up. This incident was automatically resolved by Instatus monitoring.
Investigating
15.01.2026 at 05:18
Investigating
15.01.2026 at 05:18
Citrix workspace is down at the moment. This incident was automatically created by Instatus monitoring.