Scheduled for 03.09.2025 at 12:00 – 02:00
Affects
Citrix workspace
Under maintenance from 12:00 AM to 2:00 AM
Completed
03.09.2025 at 02:00Completed
03.09.2025 at 02:00Maintenance has completed successfully
In progress
03.09.2025 at 12:00In progress
03.09.2025 at 12:00Maintenance is now in progress
Planned
03.09.2025 at 12:00Planned
03.09.2025 at 12:00We are planning for a scheduled maintenance during that time.