Deufol status of IT services - Citrix – Incident details
IT Helpdesk
Get updates
Email
SMS
Microsoft Teams
IT Helpdesk
Get updates
Dark mode
Language
All systems operational
Citrix
Resolved
Partial outage
Started 4 months ago
Lasted about 5 hours
Affected
Deufol main website
Operational from 6:20 AM to 6:22 AM, Partial outage from 6:22 AM to 11:41 AM
Updates
Resolved
25.08.2025 at 11:41
Resolved
25.08.2025 at 11:41
This incident has been resolved.
Identified
25.08.2025 at 06:22
Identified
25.08.2025 at 06:22
We are continuing to work on a fix for this incident.
Investigating
25.08.2025 at 06:20
Investigating
25.08.2025 at 06:20
We are currently investigating this incident.